Legacy web pages of Axel Beckert

Since I'm no more active at the Fachschaftsrat Informatik of the University of Saarland anymore, I have transferred all my university time legacy web pages from http://fsinfo.cs.uni-sb.de/~abe/ to this interim host at http://fsinfo.noone.org/~abe/ with only minimal modifications, mainly e-mail addresses.

Most pages on this interim host won't be updated anymore until they are moved (and redirected) step by step to their future home somewhere under http://noone.org/.

Please also note that my former e-mail address abe@fsinfo.cs.uni-sb.de is no more valid. Use abe@deuxchevaux.org instead.

Axel Beckert, Zürich, 23rd of September 2007


wApua: A WAP Browser written in PERL/Tk

Programming Republic of Perl
Just another little Perl script... :-)


Home  ·  News  ·  About  ·  Copyright  ·  Features  ·  Requirements  ·  FAQ  ·  Screen shots  ·  Download  ·  Changes  ·  Bugs  ·  Git  ·  Blog  ·  Miscellaneous  ·  WAP Links  ·  PERL Links

Requirements

PERL 5.4 or above.
wApua 0.06 and lower work with PERL 5.4 or above. wbmp2xbm 0.06 works with PERL 5.6 and above. Future wApua versions will only work with PERL 5.6 and above.
PERL 5.3 does not work. The access logs to the wApua WML home page show that at least PERL 5.4.4 works. I recommend at least 5.6.
libwww-perl (aka lwp) and HTML::Parser
libwww-perl 5.47 is fine (that means I tested it) and according to the access logs of the wApua WML home page version 5.33 also works. Earlier versions of libwww-perl may work too, but versions earlier than 5.22 shouldn't work at all, because of wApua needs HTML::TokeParser (version 3.06 and later are fine), which appeared first in the HTML::Parser package version 2.20, so no HTML::Parser version earlier than 2.20 will work. Since wApua 0.05dev at least HTML::Parser version 2.99_06 is necessary, because of earlier versions lacking XML support. (Although I found accesses from some wApua claiming to run with LWP 5.10, strange... :-)
perl/Tk 80x
At least pTk 800.019 works fine here, the access logs to the wApua WML home page show that at least pTk 800.012 works, too. pTk 400 won't work at all.

Home  ·  News  ·  About  ·  Copyright  ·  Features  ·  Requirements  ·  FAQ  ·  Screen shots  ·  Download  ·  Changes  ·  Bugs  ·  Git  ·  Blog  ·  Miscellaneous  ·  WAP Links  ·  PERL Links

$-=42;$_=qq 93233313242132627322017304228173024422013152317309;while(!!$_){$:=
$|++;s$[1-4][0-8]$$e;$==$&;$\=pack c,$;=$|.$:;$=+=$=!=$-?$-:-$=-$;;$,=$=+$-;$@
.=pack c,$!!=$--$;?!!$!!=$:?$=+$-:$,-$-:$,^$|<<chr$;+$|+$-;$!=$,;$|=$:}print$@
Copyright © 2000-2017 by Axel Beckert (abe@deuxchevaux.org)  ·  Last modification: Sun, 23-Sep-2007, 17:01:07 (CEST)
The wApua source code, the wApua web and the wApua WAP pages were all written with GNU Emacs.
The wApua logos were made with The GIMP (PNG and JPEG only; there are no GIFs) and ImageMagick (WBMP).
This page is best viewed with any browser, including text-only browsers like Lynx, w3m or links.